Server-Caudium

Il PHP 4 pu˛ essere compilato come module Pike per il server web Caudium. Attenzione: non Ŕ supportato dal Php 3. Seguire le seguenti istruzioni per installare il PHP 4 con Caudium.

Esempio 3-9. Istruzioni di installazione per Caudium

1.  Essere certi di avere installato Caudium prima di installare
    il PHP 4. Il Php per potere funzionare ha bisogno di Pike
    versione  7.0.268 o successive. Per praticitÓ di illustrazione
    in questo esempio assumeremo che Caudium sia installato in
    /opt/caudium/server/.
2.  Posizionarsi nella directory php-x.y.z (dove x.y.z Ŕ il numero di versione).
3.  ./configure --with-caudium=/opt/caudium/server
4.  make
5.  make install
6.  Riavviare Caudium se Ŕ attivo.
7.  Entrare nell'interfaccia grafica di configurazione e andare 
    nella sezione virtual server da dove si inserirÓ il PHP.
8.  Cliccare su Add Module localizzare e aggiungere il modulo PHP 4 Script Suppor.
9.  Se la documentazione informa che 'PHP 4 interpreter isn't
    available', verificare di avere riavviato il server. Se lo si Ŕ
    fatto, cercare nel file /opt/caudium/logs/debug/default.1
    la presenza di errori collegati a <filename>PHP4.so</filename>.
    Verificare anche la presenza del file 
    <filename>caudium/server/lib/[pike-version]/PHP4.so</filename>.
10. Configurare il modulo PHP Script Support se necessario..

Si pu˛ compilare il modulo per Caudium con il supporto dei vari moduli disponibili per PHP 4, Vedere la lista completa delle opzioni di configurazione options per maggiori informazioni.

Nota: Quando si compila il PHP con il supporto a MySQL occorre essere certi di utilizzare il normale client di MySQL. Altrimenti si possono verificare del conflitti se Pike supporta MySQL. Per fare ci˛ occorre specificare la directory di installazione di MySQL nell'opzione --with-mysql.